How to compiling tmux 1.5 for Ubuntu 10.04

Introduction

I’ve decide to tmux a serious try on my Ubuntu 10.04 server.

Dependencies

The first step is to install the dependencies, which are all conveniently available from the Ubuntu repositories.

This command will install the dependencies required to compile tmux from source code.

sudo apt-get install build-essential debhelper diffstat dpkg-dev fakeroot g++ g++-4.4 html2text intltool-debian libmail-sendmail-perl libncurses5-dev libstdc++6-4.4-dev libsys-hostname-long-perl po-debconf quilt xz-utils libevent-1.4-2 libevent-core-1.4-2 libevent-extra-1.4-2 libevent-dev

You may already have some of these dependencies installed, depending on if you have compiled applications from source code before.

Download

The next step is to download the source code for tmux. It can be found on SourceForge at

Extract

Now its time to extract the source code you just downloaded.

tar xvvf tmux-1.5.tar.gz

Compile

The next step is to configure and compile tmux.

This command will move into the new directory with the source code.

cd tmux/

This command will check for dependencies and configure the install. Setting --prefix will install tmux to /usr/bin, which is the same directory the package manager version of tmux installs too.

./configure --prefix=/usr

This command will make the tmux.

make

This command will install tmux to /usr/bin/tmux.

sudo make install

Conclusion Thats it, the last thing to do is start tmux.

This command will start tmux.

tmux
  • Trackback are closed
  • Comments (3)
    • Jonas
    • Aug 25th. 2011 11:47pm

    I’ve been having troubles with irssi freezing inside tmux so I figured I should update tmux. I’ve tried removing and purging the ubuntu version of tmux first but even after following your guide dpkg -s tmux says version 1.1-1?

      • Andrew Vinova
      • Aug 26th. 2011 6:10am

      Try running “tmux -V”, this way tmux is telling you its version number. Could be an issue with dpkg reporting the wrong version.

        • Jonas
        • Aug 28th. 2011 3:31pm

        Dpkg indeed seems to be the problem. Thanks!

Comment are closed.